<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width" />
<title>I&#8217;m the Bitch Who Owes Rihanna Money | The Big Jewel</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="stylesheet" type="text/css" media="all" href="http://www.thebigjewel.com/wp-content/themes/twentyeleven1/style.css" />
<link rel="pingback" href="http://www.thebigjewel.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="http://www.thebigjewel.com/wp-content/themes/twentyeleven1/js/html5.js" type="text/javascript"></script>
<![endif]-->
<link rel="alternate" type="application/rss+xml" title="The Big Jewel &raquo; Feed" href="http://www.thebigjewel.com/feed" />
<link rel="alternate" type="application/rss+xml" title="The Big Jewel &raquo; Comments Feed" href="http://www.thebigjewel.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="The Big Jewel &raquo; I&#8217;m the Bitch Who Owes Rihanna Money Comments Feed" href="http://www.thebigjewel.com/im-the-bitch-who-owes-rihanna-money/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/www.thebigjewel.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.5.6"}};
			!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;if(!g||!g.fillText)return!1;switch(g.textBaseline="top",g.font="600 32px Arial",a){case"flag":return g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3;case"diversity":return g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,d=c[0]+","+c[1]+","+c[2]+","+c[3],g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e;case"simple":return g.fillText(h(55357,56835),0,0),0!==g.getImageData(16,16,1,1).data[0];case"unicode8":return g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.thebigjewel.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='A2A_SHARE_SAVE-css'  href='http://www.thebigjewel.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.12' type='text/css' media='all' />
<script type='text/javascript' src='http://www.thebigjewel.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.thebigjewel.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://www.thebigjewel.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.thebigjewel.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.thebigjewel.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Employment Can Strike Anyone' href='http://www.thebigjewel.com/employment-can-strike-anyone' />
<meta name="generator" content="WordPress 4.5.6" />
<link rel="canonical" href="http://www.thebigjewel.com/im-the-bitch-who-owes-rihanna-money" />
<link rel='shortlink' href='http://wp.me/p22rSM-Ux' />
<link rel="alternate" type="application/json+oembed" href="http://www.thebigjewel.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.thebigjewel.com%2Fim-the-bitch-who-owes-rihanna-money" />
<link rel="alternate" type="text/xml+oembed" href="http://www.thebigjewel.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.thebigjewel.com%2Fim-the-bitch-who-owes-rihanna-money&#038;format=xml" />

	<!-- Add RSS feeds -->
				
	<!-- Add RSS (end) -->


<script type="text/javascript"><!--
var a2a_config=a2a_config||{},wpa2a={done:false,html_done:false,script_ready:false,script_load:function(){var a=document.createElement('script'),s=document.getElementsByTagName('script')[0];a.type='text/javascript';a.async=true;a.src='http://static.addtoany.com/menu/page.js';s.parentNode.insertBefore(a,s);wpa2a.script_load=function(){};},script_onready:function(){wpa2a.script_ready=true;if(wpa2a.html_done)wpa2a.init();},init:function(){for(var i=0,el,target,targets=wpa2a.targets,length=targets.length;i<length;i++){el=document.getElementById('wpa2a_'+(i+1));target=targets[i];a2a_config.linkname=target.title;a2a_config.linkurl=target.url;a2a_config.linkmedia=target.media;if(el){a2a.init('page',{target:el});el.id='';}wpa2a.done=true;}wpa2a.targets=[];}};a2a_config.callbacks=a2a_config.callbacks||[];a2a_config.callbacks.push({ready:wpa2a.script_onready});a2a_config.templates=a2a_config.templates||{};
//--></script>
<script type="text/javascript">
	window._se_plugin_version = '8.1.5';
</script>

<link rel='dns-prefetch' href='//v0.wordpress.com'>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="I&#8217;m the Bitch Who Owes Rihanna Money" />
<meta property="og:url" content="http://www.thebigjewel.com/im-the-bitch-who-owes-rihanna-money" />
<meta property="og:description" content="Hey girl! How are you? Okay, I&#8217;m not gonna mince words here. When I heard your song &#8220;Bitch Better Have My Money,&#8221; I loved it. So catchy! Then I listened to the song another eighty…" />
<meta property="article:published_time" content="2017-02-08T20:00:27+00:00" />
<meta property="article:modified_time" content="2017-01-22T18:32:21+00:00" />
<meta property="og:site_name" content="The Big Jewel" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:card" content="summary" />
</head>

<body class="single single-post postid-3505 single-format-standard singular two-column right-sidebar">
<div id="page" class="hfeed">
	<header id="branding" role="banner">
			<hgroup>
				<h1 id="site-title"><span><a href="http://www.thebigjewel.com/" title="The Big Jewel" rel="home">The Big Jewel</a></span></h1>
				<h2 id="site-description">Not Affiliated with &#039;Al&#039;s Jiant Jewel Warehouse&#039;</h2>
			</hgroup>

						<a href="http://www.thebigjewel.com/">
									<img src="http://www.thebigjewel.com/wp-content/uploads/2014/04/bjlogo.gif" width="1000" height="200" alt="" />
							</a>
			
								<form method="get" id="searchform" action="http://www.thebigjewel.com/">
		<label for="s" class="assistive-text">Search</label>
		<input type="text" class="field" name="s" id="s" placeholder="Search" />
		<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
	</form>
			
			<nav id="access" role="navigation">
				<h3 class="assistive-text">Main menu</h3>
								<div class="skip-link"><a class="assistive-text" href="#content" title="Skip to primary content">Skip to primary content</a></div>
				<div class="skip-link"><a class="assistive-text" href="#secondary" title="Skip to secondary content">Skip to secondary content</a></div>
								<div class="menu"><ul><li ><a href="http://www.thebigjewel.com/">Home</a></li><li class="page_item page-item-2"><a href="http://www.thebigjewel.com/about">About</a></li><li class="page_item page-item-1886"><a href="http://www.thebigjewel.com/advertise">Advertise</a></li><li class="page_item page-item-640"><a href="http://www.thebigjewel.com/archivepage">Archives</a></li><li class="page_item page-item-6"><a href="http://www.thebigjewel.com/blurbs">Blurbs</a></li><li class="page_item page-item-15"><a href="http://www.thebigjewel.com/contact">Contact</a></li><li class="page_item page-item-24"><a href="http://www.thebigjewel.com/exposure">Exposure</a></li><li class="page_item page-item-22"><a href="http://www.thebigjewel.com/submissions">Submissions</a></li></ul></div>
			</nav><!-- #access -->
	</header><!-- #branding -->


	<div id="main">

		<div id="primary">
			<div id="content" role="main">

				
					<nav id="nav-single">
						<h3 class="assistive-text">Post navigation</h3>
						<span class="nav-previous"><a href="http://www.thebigjewel.com/employment-can-strike-anyone" rel="prev"><span class="meta-nav">&larr;</span> Previous</a></span>
						<span class="nav-next"></span>
					</nav><!-- #nav-single -->

					
<article id="post-3505" class="post-3505 post type-post status-publish format-standard hentry category-Articles tag-anita-gill">
	<header class="entry-header">

		
		<h1 class="entry-title">I&#8217;m the Bitch Who Owes Rihanna Money</h1>

By: <a href="http://www.thebigjewel.com/tag/anita-gill" rel="tag">Anita Gill</a><BR>
<a href="mailto:annie.m.gill@gmail.com">annie.m.gill@gmail.com</a><br />
<a href=""></a>





			  <div class="entry-meta">
			<span class="sep">Posted on </span><a href="http://www.thebigjewel.com/im-the-bitch-who-owes-rihanna-money" title="12:00 pm" rel="bookmark"><time class="entry-date" datetime="2017-02-08T12:00:27+00:00">February 8, 2017</time></a><span class="by-author"> <span class="sep"> by </span> <span class="author vcard"><a class="url fn n" href="http://www.thebigjewel.com/author/kurt" title="View all posts by kurt" rel="author">kurt</a></span></span>		</div><!-- .entry-meta -->
			</header><!-- .entry-header -->

	<div class="entry-content">
		<p>Hey girl! How are you?</p>
<p>Okay, I&#8217;m not gonna mince words here. When I heard your song &#8220;Bitch Better Have My Money,&#8221; I loved it. So catchy! Then I listened to the song another eighty times and I noticed your penchant for repetition on poignant lines, specifically that someone, a bitch perhaps, owes you money. That&#8217;s when it struck me. I knew exactly to whom you were referring. I messed up. I owe you. It totally slipped my mind. Honestly! I&#8217;m not acting like I forgot and I am certainly not frontin&#8217;!</p>
<p>My friends say you wrote it in response to some accounting snafu from a few years back. I don&#8217;t believe a word of that. I know you, RiRi. Yeah, I know there&#8217;s the line, &#8220;Your wife in the backseat of my brand new foreign car,&#8221; but I think that&#8217;s an allusion to me, right? You let me borrow your Volvo S90 that one night so I could convince my parents I was financially stable. I&#8217;ll be honest that the &#8220;wife in the car&#8221; line tripped me up. But then I remembered our late night run to In-N-Out Burger where I admitted that I would marry my sandwich if the California courts permitted it. You thought I was crazy to buckle up our order in the backseat, but then I proved to you that it wouldn&#8217;t spill on your nice car, didn&#8217;t I? It&#8217;s like I always say: with food, safety first!</p>
<p>Your song alludes to the fact I still owe you money from that night at T.G.I. Friday&#8217;s, right? That&#8217;s when we last hung out. There&#8217;s a line in your song, &#8220;Louis XIII and it&#8217;s all on me.&#8221; We were drinking and we played which monarch from the House of Bourbon would you bang, right? Oh, the laughs we had! I was low on cash and you said you&#8217;d spot my cocktail? I think I ordered a Diddy on the Beach? And then we split those potato skins? Man, that was a great night.</p>
<p>On top of it all, you surprised me with that gift of a sheer tank top that makes my nipples super visible. That was so thoughtful! I guess you overlooked my soul-crushing anxiety about being naked, and how I always had to dart to the two bathroom stalls in the high school girls&#8217; locker room to change for gym. Or maybe you&#8217;re trying to get me to face my fears about my body. The tank is lovely, nonetheless. I haven&#8217;t worn it to work like you suggested, but I did wear it to my girlfriend&#8217;s baby shower and they were speechless. Thanks, girl!</p>
<p>I&#8217;m so sorry we haven&#8217;t hung out since that drink date. I knew you were getting ready for the Met Gala and requested your next dress to be forged with Valyrian steel and unicorn tears (so cool that those things exist for famous people!). I&#8217;ve been busy, too. Most of my energy is going into my new business venture: selling wool scarves from a Scottish sheep farm on Etsy. It&#8217;s been my dream ever since I went to grad school and realized how financially fucked I was by earning more degrees in the Humanities instead of just becoming an Accountant. That&#8217;s when I wondered: what does everyone need? Scarves! But don&#8217;t think I&#8217;m here looking for handouts. Really, I&#8217;m fine. Please don&#8217;t think this is one of those friendships with a non-famous friend who mooches. I have every desire to pay you back in full.</p>
<p>As I remember, I owe you $23.72 correct? I&#8217;m writing the check right now!</p>
<p>Then let&#8217;s put this behind us. Remember when we first became friends? Back at the Good Girl Gone Bad Tour when I accidentally walked into your trailer looking for a bathroom? You complimented me on the Bedazzled fanny pack I was wearing to keep my money and Chapstick and I explained how my jeweled accessory was a double threat &#8212; both fashionable and practical. You told me I was the weirdest, most down-to-earth bitch you ever met, remember? Then you said you needed more real bitches in your life and you invited me to come back again with my Bedazzler. That&#8217;s when I knew we would be lasting friends. I hope I am still that real bitch you can trust, Rihanna. Because I value our friendship.</p>
<p>Also, would you like to buy a scarf? They&#8217;re authentic Scottish sheep wool. They&#8217;d make great stocking stuffers for the holidays. Just a thought.</p>
<p>Hugs,</p>
<p>Anita</p>
<p>&nbsp;</p>
<div class="addtoany_share_save_container addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_ addtoany_list a2a_target" id="wpa2a_1"><a class="a2a_dd addtoany_share_save" href="https://www.addtoany.com/share"><img src="http://www.thebigjewel.com/wp-content/plugins/add-to-any/share_save_171_16.png" width="171" height="16" alt="Share"/></a>
<script type="text/javascript"><!--
if(wpa2a)wpa2a.script_load();
//--></script>
</div></div>			</div><!-- .entry-content -->

	<footer class="entry-meta">
		This entry was posted in <a href="http://www.thebigjewel.com/category/Articles" rel="category tag">Articles</a> and tagged <a href="http://www.thebigjewel.com/tag/anita-gill" rel="tag">Anita Gill</a>. Bookmark the <a href="http://www.thebigjewel.com/im-the-bitch-who-owes-rihanna-money" title="Permalink to I&#8217;m the Bitch Who Owes Rihanna Money" rel="bookmark">permalink</a>.		
		        <center><P>&nbsp;</P><img src="images/logotiny.gif" /><P></center>
	</footer><!-- .entry-meta -->
</article><!-- #post-3505 -->

						<div id="comments">
	
	
			<h2 id="comments-title">
			One thought on &ldquo;<span>I&#8217;m the Bitch Who Owes Rihanna Money</span>&rdquo;		</h2>

		
		<ol class="commentlist">
				<li class="comment even thread-even depth-1" id="li-comment-210989">
		<article id="comment-210989" class="comment">
			<footer class="comment-meta">
				<div class="comment-author vcard">
					<img alt='' src='http://2.gravatar.com/avatar/294469d7fe64891bf1aae0491e633169?s=68&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/294469d7fe64891bf1aae0491e633169?s=136&amp;d=mm&amp;r=g 2x' class='avatar avatar-68 photo' height='68' width='68' /><span class="fn">Sylvia Gill</span> on <a href="http://www.thebigjewel.com/im-the-bitch-who-owes-rihanna-money#comment-210989"><time datetime="2017-02-09T16:32:10+00:00">February 9, 2017 at 4:32 pm</time></a> <span class="says">said:</span>
									</div><!-- .comment-author .vcard -->

				
			</footer>

			<div class="comment-content"><p>Great read! So entertaining!  Thanks</p>
</div>

			<div class="reply">
				<a rel='nofollow' class='comment-reply-link' href='http://www.thebigjewel.com/im-the-bitch-who-owes-rihanna-money?replytocom=210989#respond' onclick='return addComment.moveForm( "comment-210989", "210989", "respond", "3505" )' aria-label='Reply to Sylvia Gill'>Reply <span>&darr;</span></a>			</div><!-- .reply -->
		</article><!-- #comment-## -->

	</li><!-- #comment-## -->
		</ol>

		
		
	
					<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/im-the-bitch-who-owes-rihanna-money#respond" style="display:none;">Cancel reply</a></small></h3>				<form action="http://www.thebigjewel.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
					<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='3505' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="24580ba80c" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="116"/></p>				</form>
					</div><!-- #respond -->
		
</div><!-- #comments -->

				
			</div><!-- #content -->
		</div><!-- #primary -->


	</div><!-- #main -->

	<footer id="colophon" role="contentinfo">

			

			<div id="site-generator">
								<a href="http://wordpress.org/" title="Semantic Personal Publishing Platform">Proudly powered by WordPress</a>
			</div>
	</footer><!-- #colophon -->
</div><!-- #page -->


<script type="text/javascript"><!--
wpa2a.targets=[
{title:"I\u2019m the Bitch Who Owes Rihanna Money",url:"http://www.thebigjewel.com/im-the-bitch-who-owes-rihanna-money"}];
wpa2a.html_done=true;if(wpa2a.script_ready&&!wpa2a.done)wpa2a.init();wpa2a.script_load();
//--></script>
	<div style="display:none">
	<div class="grofile-hash-map-6d3c06d88a2e69caf93d8df90fe5a841">
	</div>
	</div>
<script type='text/javascript' src='http://www.thebigjewel.com/wp-content/plugins/akismet/_inc/form.js?ver=3.1.11'></script>
<script type='text/javascript' src='http://www.thebigjewel.com/wp-includes/js/comment-reply.min.js?ver=4.5.6'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201706'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.thebigjewel.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.5.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var SlimStatParams = {"ajaxurl":"http:\/\/www.thebigjewel.com\/wp-admin\/admin-ajax.php","async_tracker":"false","extensions_to_track":"pdf,doc,xls,zip","outbound_classes_rel_href_to_not_track":"noslimstat,ab-item","ci":"YTo0OntzOjEyOiJjb250ZW50X3R5cGUiO3M6NDoicG9zdCI7czo4OiJjYXRlZ29yeSI7czo1OiIxLDMwMCI7czoxMDoiY29udGVudF9pZCI7aTozNTA1O3M6NjoiYXV0aG9yIjtzOjQ6Imt1cnQiO30=.d4143de9005e5485ffb550527c8bd025"};
/* ]]> */
</script>
<script type='text/javascript' src='http://cdn.jsdelivr.net/wp/wp-slimstat/trunk/wp-slimstat.min.js'></script>
<script type='text/javascript' src='http://www.thebigjewel.com/wp-includes/js/wp-embed.min.js?ver=4.5.6'></script>
<script type='text/javascript' src='http://stats.wp.com/e-201706.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.0.3',blog:'30136512',post:'3505',tz:'-8',srv:'www.thebigjewel.com'} ]);
	_stq.push([ 'clickTrackerInit', '30136512', '3505' ]);
</script>

</body>
</html>